You cannot select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
simulacion-permeabilidad/shell.nix

18 lines
408 B
Nix

# nix-shell -p [ (python3Full.withPackages(ps: with ps; [ pip ])) gfortran zlib]
with import <nixpkgs> {};
stdenv.mkDerivation {
name = "python-env-petsc";
nativeBuildInputs = [ m4 removeReferencesTo ];
buildInputs = [ (python3Full.withPackages(ps: with ps; [ pip ]))
gfortran
zlib
gcc
];
dontAddPrefix=true;
env.LD_LIBRARY_PATH = zlib + "/lib:" + stdenv.cc.cc.lib + "/lib";
}